+ Reply to Thread
Results 1 to 6 of 6

Thread: Mac OS installer issue

  1. #1
    Junior Member
    Join Date
    Apr 2012
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Mac OS installer issue

    Your Mac installer, I believe, must have installed a launch daemon. I don't see it in any of the typical locations, like

    launchctl list
    ~/Library/StartupItems
    /Library/StartupItems
    SystemPrefs | user | Login Items

    So how is it being launched? I want to turn this off, and only run ES5 when I choose to run the script.

  2. #2
    Former Administrator tcarr's Avatar
    Join Date
    Dec 2007
    Posts
    7,701
    Thanks
    84
    Thanked 1,178 Times in 1,165 Posts
    This is the first time I've heard of this. What makes you suspect it? When you restart your OS, is the ES5 started automatically?

    Please note that the usual way to start ES5 starts a bootstrap process, which then spawns a background process that runs ES5. It's possible this is what you are referring to. If you don't want that to happen, use the SAFEMODE script instead, which keeps it all in a single process.
    Teresa Carrigan
    Senior Software Developer
    Janus Research Group, Inc.
    previously
    Senior Engineer
    Electrotank, Inc.

  3. #3
    Junior Member
    Join Date
    Apr 2012
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts
    ES5 starts automatically, and it appears your Mac installer has installed a launch daemon. Seeing this in my Console.app too

    4/30/12 9:30:19.027 AM com.install4j.6594-8422-0284-4253.ElectroServer_5_3_2_Service: Starting ElectroServer_5_3_2_Service

  4. #4
    Former Administrator tcarr's Avatar
    Join Date
    Dec 2007
    Posts
    7,701
    Thanks
    84
    Thanked 1,178 Times in 1,165 Posts
    I'll have Jason look into this. (I don't have a Mac myself)
    Teresa Carrigan
    Senior Software Developer
    Janus Research Group, Inc.
    previously
    Senior Engineer
    Electrotank, Inc.

  5. #5
    Junior Member
    Join Date
    Apr 2012
    Posts
    18
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ah OK, I found it:
    /Library/LaunchDaemons/com.install4j.6594-8422-0284-4253.ElectroServer_5_3_2_Service.plist

  6. #6
    Former Administrator tcarr's Avatar
    Join Date
    Dec 2007
    Posts
    7,701
    Thanks
    84
    Thanked 1,178 Times in 1,165 Posts
    Glad you found it. Is it possible that at one time you started ES5 by using the Service link instead of the normal one?
    Teresa Carrigan
    Senior Software Developer
    Janus Research Group, Inc.
    previously
    Senior Engineer
    Electrotank, Inc.

+ Reply to Thread

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts